Auto Repair Q&A

Popular

Engine

Cooling System

Brakes

Suspension

Transmission

Exhaust/Emissions

Electrical

Body

Interior

Understand

Directory

Auto Repair Products

I have a 2002 Nissan Sentra GXE. The heater is only blowing cold air...temp gauge moves normally. I replaced the thermostat. I noticed the 2 hoses into the firewall were not warm. Could they be clogged? How hard is it to access the heater core?

  • Warning: include() [<a href='function.include'>function.include</a>]: Unable to allocate memory for pool. in theme_render_template() (line 1079 of /var/local/www/10w40.com/includes/theme.inc).
  • Warning: include() [<a href='function.include'>function.include</a>]: Unable to allocate memory for pool. in theme_render_template() (line 1079 of /var/local/www/10w40.com/includes/theme.inc).
  • Warning: include() [<a href='function.include'>function.include</a>]: Unable to allocate memory for pool. in theme_render_template() (line 1079 of /var/local/www/10w40.com/includes/theme.inc).
  • Warning: include() [<a href='function.include'>function.include</a>]: Unable to allocate memory for pool. in theme_render_template() (line 1079 of /var/local/www/10w40.com/includes/theme.inc).
  • Warning: include() [<a href='function.include'>function.include</a>]: Unable to allocate memory for pool. in theme_render_template() (line 1079 of /var/local/www/10w40.com/includes/theme.inc).
  • Warning: require_once() [<a href='function.require-once'>function.require-once</a>]: Unable to allocate memory for pool. in views_include_handler() (line 98 of /var/local/www/10w40.com/modules/views/includes/handlers.inc).
  • Warning: require_once() [<a href='function.require-once'>function.require-once</a>]: Unable to allocate memory for pool. in views_include_handler() (line 98 of /var/local/www/10w40.com/modules/views/includes/handlers.inc).
  • Warning: require_once() [<a href='function.require-once'>function.require-once</a>]: Unable to allocate memory for pool. in views_include_handler() (line 98 of /var/local/www/10w40.com/modules/views/includes/handlers.inc).
  • Warning: require_once() [<a href='function.require-once'>function.require-once</a>]: Unable to allocate memory for pool. in views_include_handler() (line 98 of /var/local/www/10w40.com/modules/views/includes/handlers.inc).
  • Warning: require_once() [<a href='function.require-once'>function.require-once</a>]: Unable to allocate memory for pool. in views_include_handler() (line 98 of /var/local/www/10w40.com/modules/views/includes/handlers.inc).

have you ever done a radiator

have you ever done a radiator flush? take the heater hoses loose at the engine and force water thru on and have a container for the other to see what comes out - do it gradually not full force.

and check the thermal control

and check the thermal control valve its may be bad

you might not be getting

you might not be getting coolant to your heater core, try bleeding you coolant system and check your coolant leval

pull off the return hose and

pull off the return hose and place it in a jug, start engin for a second and see if it flows out with enogh volume to fill the hose. if it doesn't the heater core is restricted and will have to be flushed or replaced.


Auto Repair Q&A Contest

Win Cash!

Participate in the 10w40.com Q&A community to win cash prizes!

win cash prizes

Congratulations to our August Winners!

How To Play

 

Top Contributors: 2 weeks